CRAN Package Check Results for Package geoknife

Last updated on 2020-05-29 01:50:10 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.6.3 9.68 59.20 68.88 OK
r-devel-linux-x86_64-debian-gcc 1.6.3 7.25 46.43 53.68 ERROR
r-devel-linux-x86_64-fedora-clang 1.6.3 81.95 OK
r-devel-linux-x86_64-fedora-gcc 1.6.3 83.15 OK
r-devel-windows-ix86+x86_64 1.6.3 24.00 113.00 137.00 OK
r-patched-linux-x86_64 1.6.3 9.51 58.65 68.16 OK
r-patched-solaris-x86 1.6.3 120.40 OK
r-release-linux-x86_64 1.6.3 8.20 59.19 67.39 OK
r-release-osx-x86_64 1.6.3 OK
r-release-windows-ix86+x86_64 1.6.3 18.00 132.00 150.00 OK
r-oldrel-osx-x86_64 1.6.3 OK
r-oldrel-windows-ix86+x86_64 1.6.3 15.00 87.00 102.00 OK

Check Details

Version: 1.6.3
Check: tests
Result: ERROR
     Running ‘testthat.R’ [3s/11s]
    Running the tests in ‘tests/testthat.R’ failed.
    Complete output:
     > library(testthat)
     > test_check('geoknife')
     Loading required package: geoknife
    
     Attaching package: 'geoknife'
    
     The following object is masked from 'package:stats':
    
     start
    
     The following object is masked from 'package:graphics':
    
     title
    
     The following object is masked from 'package:base':
    
     url
    
     ── 1. Error: geoknife converts SpatialPolygons to simplegeoms correctly (@test-g
     "+proj=longlat +datum=WGS84 +no_defs" not supported for "simplegeom", use "+proj=longlat +datum=WGS84"
     Backtrace:
     1. testthat::expect_is(simplegeom(SP), "simplegeom")
     5. geoknife::simplegeom(SP)
     6. methods::as(.Object, "simplegeom")
     7. geoknife:::asMethod(object)
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     [ OK: 70 | SKIPPED: 67 | WARNINGS: 2 | FAILED: 1 ]
     1. Error: geoknife converts SpatialPolygons to simplegeoms correctly (@test-geoknife_setters.R#45)
    
     Error: testthat unit tests failed
     In addition: Warning message:
     In extract_lang(f = comp_lang, y = quote(if (.isMethodsDispatchOn() && :
     devtools is incompatible with the current version of R. `load_all()` may function incorrectly.
     Execution halted
Flavor: r-devel-linux-x86_64-debian-gcc