CRAN Package Check Results for Package plot3logit

Last updated on 2020-04-05 02:50:40 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.2 0.49 2.50 2.99 ERROR
r-devel-linux-x86_64-debian-gcc 1.0.2 0.41 2.04 2.45 ERROR
r-devel-linux-x86_64-fedora-clang 1.0.2 2.48 ERROR
r-devel-linux-x86_64-fedora-gcc 1.0.2 2.49 ERROR
r-devel-windows-ix86+x86_64 1.0.2 14.00 70.00 84.00 ERROR
r-devel-windows-ix86+x86_64-gcc8 1.0.2 16.00 68.00 84.00 ERROR
r-patched-linux-x86_64 1.0.2 0.47 2.61 3.08 ERROR
r-patched-solaris-x86 1.0.2 4.90 ERROR
r-release-linux-x86_64 1.0.2 0.40 2.29 2.69 ERROR
r-release-windows-ix86+x86_64 1.0.2 14.00 110.00 124.00 ERROR
r-release-osx-x86_64 1.0.2 OK
r-oldrel-windows-ix86+x86_64 1.0.2 9.00 80.00 89.00 ERROR
r-oldrel-osx-x86_64 1.0.2 OK

Check Details

Version: 1.0.2
Check: package dependencies
Result: ERROR
    Package required but not available: 'ggtern'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64

Version: 1.0.2
Check: examples
Result: ERROR
    Running examples in 'plot3logit-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: field3logit
    > ### Title: Computation of the vector field
    > ### Aliases: field3logit plot3logit print.field3logit plot.field3logit
    > ### as.data.frame.field3logit fortify.field3logit
    >
    > ### ** Examples
    >
    > data(cross_1year)
    >
    > # Model fit
    > mod0 <- nnet::multinom(employment_sit ~ finalgrade + irregularity + hsscore,
    + cross_1year)
    # weights: 21 (12 variable)
    initial value 3605.645531
    iter 10 value 2187.709284
    iter 20 value 2157.087955
    final value 2157.087854
    converged
    > mod0
    Call:
    nnet::multinom(formula = employment_sit ~ finalgrade + irregularity +
     hsscore, data = cross_1year)
    
    Coefficients:
     (Intercept) finalgradeLow finalgradeHigh irregularityLow
    Unemployed -0.4481761 0.05551765 -0.07810893 -0.01874354
    Trainee -1.3751140 0.14456683 -0.26849829 0.05764144
     irregularityHigh hsscore
    Unemployed 0.15691595 -0.016619227
    Trainee -0.03477569 -0.009964381
    
    Residual Deviance: 4314.176
    AIC: 4338.176
    >
    > # Assessing the effect of "finalgradeHigh" (explicit notation)
    > field0 <- field3logit(mod0, c(0, 0, 1, 0, 0, 0))
    > gg3logit(field0) + stat_3logit()
    Error: $ operator is invalid for atomic vectors
    Execution halted
Flavors: r-devel-windows-ix86+x86_64, r-devel-windows-ix86+x86_64-gcc8, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.0.2
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'plot3logit-overview.Rmd' using rmarkdown
    Loading required package: ggtern
    Loading required package: ggplot2
    --
    Remember to cite, run citation(package = 'ggtern') for further info.
    --
    
    Attaching package: 'ggtern'
    
    The following objects are masked from 'package:ggplot2':
    
     %+%, aes, annotate, calc_element, ggplot, ggplotGrob, ggplot_build,
     ggplot_gtable, ggsave, layer_data, theme, theme_bw, theme_classic,
     theme_dark, theme_gray, theme_light, theme_linedraw, theme_minimal,
     theme_void
    
    Loading required package: Ternary
    Quitting from lines 95-96 (plot3logit-overview.Rmd)
    Error: processing vignette 'plot3logit-overview.Rmd' failed with diagnostics:
    $ operator is invalid for atomic vectors
    --- failed re-building 'plot3logit-overview.Rmd'
    
    SUMMARY: processing the following file failed:
     'plot3logit-overview.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavors: r-devel-windows-ix86+x86_64, r-devel-windows-ix86+x86_64-gcc8, r-release-windows-ix86+x86_64

Version: 1.0.2
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Loading required package: ggtern
    Loading required package: ggplot2
    --
    Remember to cite, run citation(package = 'ggtern') for further info.
    --
    
    Attaching package: 'ggtern'
    
    The following objects are masked from 'package:ggplot2':
    
     %+%, aes, annotate, calc_element, ggplot, ggplotGrob, ggplot_build,
     ggplot_gtable, ggsave, layer_data, theme, theme_bw, theme_classic,
     theme_dark, theme_gray, theme_light, theme_linedraw, theme_minimal,
     theme_void
    
    Loading required package: Ternary
    Quitting from lines 95-96 (plot3logit-overview.Rmd)
    Error: processing vignette 'plot3logit-overview.Rmd' failed with diagnostics:
    $ operator is invalid for atomic vectors
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64